AnsweredAssumed Answered

Impala Insallation Error

Question asked by shubham.mbd on Nov 2, 2017
Latest reply on Nov 13, 2017 by maprcommunity

I installed impala2.5 on a single node , it was showing in the failed state. 

 

After Installation , in the MCS fisrst for 2-3 minutes it is showing in the standby state , and after that it is showing in the failed state . 

Hive is working properly . I checked by running Map-Reduce Job.successfully executed 

 

I seen the Log , in the impala-catalogd section following come :

I1102 12:22:05.390668 28892 GlogAppender.java:123] Logging initialized. Impala: INFO, All other: INFO
I1102 12:22:05.391485 28892 JniCatalog.java:92] Java Version Info: OpenJDK Runtime Environment (1.7.0_151-mockbuild_2017_08_09_21_42-b00)
E1102 12:22:05.403759 28892 catalog.cc:70] java.lang.NoClassDefFoundError: org/apache/hadoop/hive/metastore/api/UnknownDBException
at com.cloudera.impala.service.JniCatalog.<init>(JniCatalog.java:94)
Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hive.metastore.api.UnknownDBException
at java.net.URLClassLoader$1.run(URLClassLoader.java:359)
at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
... 1 more

Outcomes