AnsweredAssumed Answered

Has anyone been able to get Spring/Yarn working on MapR 5.2.1.42646.GA

Question asked by jmontane on Oct 13, 2017
Latest reply on Nov 8, 2017 by maprcommunity

Has anyone been able to get Spring/Yarn working on MapR 5.2.1.42646.GA ?

I would appreciate anyone sharing their experience on this and if they were able to get the HelloPojo to run successfully.


Thanks in advance,

Joe

 

I've followed instructions here:

Getting Started · Simple YARN Application 

 

I'm getting the following stack trace:

 

I've set the fsUri to

---------------------------------------------------------------------------

* fsUri: maprfs:///

 

I've added the following dependencies to the pom.xml

---------------------------------------------------------------------------

<dependency>
  <groupId>org.apache.hadoop</groupId>
  <artifactId>hadoop-core</artifactId>
  <version>1.0.3-mapr-5.2.1</version>

<dependency>

<dependency>

  <groupId>org.apache.hadoop</groupId>
  <artifactId>hadoop-common</artifactId>
  <version>2.7.0-mapr-1703</version>
</dependency>
<dependency>
  <groupId>com.mapr.hadoop</groupId>
  <artifactId>maprfs</artifactId>
  <version>2.7.0-mapr-1703</version>
</dependency>
<dependency>
  <groupId>com.mapr.hadoop</groupId>
  <artifactId>maprfs-jni</artifactId>
  <version>2.7.0-mapr-1703</version>
</dependency>
<dependency>
  <groupId>org.apache.hadoop</groupId>
  <artifactId>hadoop-yarn-common</artifactId>
  <version>2.7.0-mapr-1703</version>
</dependency>
<dependency>
  <groupId>org.apache.hadoop</groupId>
  <artifactId>hadoop-yarn-api</artifactId>
  <version>2.7.0-mapr-1703</version>
</dependency>
<dependency>
  <groupId>org.apache.hadoop</groupId>
  <artifactId>hadoop-yarn-client</artifactId>
  <version>2.7.0-mapr-1703</version>
</dependency>

Outcomes