AnsweredAssumed Answered

MapR installer 1.6 error

Question asked by srd35 on Sep 11, 2017
Latest reply on Sep 14, 2017 by maprcommunity

Hi,

 

Since the lastest version of mapr installer 1.6 (27 august 2017) I can't deploy new cluster.

 

I have

2017-09-11 17:42:47.829: Task: Verify prerequisites cpu={{ ansible_architecture }} disks={{mapr.node.disks|join(",")}} devices='{{ansible_devices|to_json}}' mounts='{{ ansible_mounts|to_json}}' ram={{ansible_memtotal_mb}} swap={{ansible_swaptotal_mb}} home={{mapr_home}} fqdn={{ansible_fqdn}} distro={{ ansible_distribution }} distro_ver={{ ansible_distribution_version }} core_ver={{ version }} create_admin='{{ cluster_admin_create }}' admin_user='{{ cluster_admin_id }}' admin_uid='{{ cluster_admin_uid }}' admin_gid='{{ cluster_admin_gid }}' admin_group='{{ cluster_admin_group }}' data='{{ mapr.node|to_json }}' security='{{ security }}' no_internet='{{ no_internet }}' is_cloud='{{ True if provider is defined else False }}' cloud_provider='{{ "" if provider is not defined else provider.id }}' -> failed  =>  {"changed": false, "failed": true, "module_stderr": "Shared connection to lfrn1mapr01.siradel.local closed.\r\n", "module_stdout": "\r\nTraceback (most recent call last):\r\n  File \"/tmp/ansible_aMon_1/ansible_module_mapr_prereq.py.py\", line 842, in <module>\r\n    main()\r\n  File \"/tmp/ansible_aMon_1/ansible_module_mapr_prereq.py.py\", line 840, in main\r\n    prereq.run_checks()\r\n  File \"/tmp/ansible_aMon_1/ansible_module_mapr_prereq.py.py\", line 138, in run_checks\r\n    self.payload['prereqs'].update(func())\r\n  File \"/tmp/ansible_aMon_1/ansible_module_mapr_prereq.py.py\", line 544, in check_disks\r\n    if dev not in fdisk_output:\r\nUnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 117: ordinal not in range(128)\r\n", "rc": 0} MODULE FAILURE

on all nodes (and I have the same problem if I try on 1 node)

 

I use Ubuntu 14.04 and in the same configuration with mapr version 5.2.0 I had no problems...

 

So, is it possible to have the old installer ? Or there are some issues about this problem ?

Outcomes