AnsweredAssumed Answered

Mapr-Hue : No module named google_compute_engine

Question asked by DUCNGO on Aug 21, 2017
Latest reply on Aug 29, 2017 by maprcommunity

Hello, 

 

I was trying to install Mapr Single Node on Google Compute Engine 

 

Environment : Centos 7.3, Ubuntu 14.04 LTS and 16.04 LTS - imaged provided by google. 

 

My Hue service cannot start (in Centos) or cannot install (either Mapr Installer or sudo apt-get install mapr) due to single reason 

 

ImportError: Could not import settings 'desktop.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named google_compute_engine

 

In Ubutuntu 14.04 LTS, i cannot install mapr-hue using Web Installer, it will cause error as above. Other service run fine 

in Ubuntu 16.04 LTS, I can install the Mapr-Hue using web installer, but cannot start the service. 

In Centos 7.3, I can install easily all the service, but HUE are not able to run - checked the log. it has the same error as Mapr-hue installation on Ubuntu. 

 

I have done many trouble shooting on those platforms to find the root cause or similar issues, tried all the way, so far no result. 

 

My best guess : Mapr-Hue package or related python dependencies are not compatible with google compute engine. 

 

Need help from the community.

 

 

Regards

 

Duc

 

Outcomes