AnsweredAssumed Answered

Requesting Information about MapR Sandbox

Question asked by eddylee on Jun 28, 2017
Latest reply on Jun 28, 2017 by eddylee

Hi MapR and everybody,

 

I have downloaded both MapR-Sandbox-For-Apache-Drill-1.10.0-5.2.1-vmware.ova and MapR-Sandbox-For-Hadoop-5.2.1-vmware.ova to test out latest MapR features however I bumped into a couple of errors while tried to import the VM image.

 

My host environment is:

Windows 7 Pro 64 Bit. 16GB RAM. 100GB free space. VT enabled.

VMPlayer ver 7

VMWorkstation ver 11

And I managed to run other Hadoop distro sandbox without any issue.

 

Errors that I encountered include:

1. OVF compliance check failed but it lets me continue.

2. Then while importing halfway, a SHA1 checksum not matched occured and import process terminated.

 

I tried also to manually import the VMDK files and recreate the VM image, however the guest filesystem/partition is unable to be mounted as read write. I used fciv sha1 to generate SHA1 checksum for the VMDK, it seems the checksum doesn't match the one in MF file.

 

I suspect it may have to do with my environment or my download (I did download a few times) as I see not many complaints about the sandbox. I would like to suggest to MapR team to provide more information about the sandbox at the download web site.

 

1. Provide MD5/ SHA1 checksum for the image downloads so that downloader can rule out any file corruption during downloading.

 

2. Specify any particular version/edition of VMWare and VirtualBox that is supported by the sandbox. I believe the generated OVA/OVF is specific to certain version and above.

 

At the meantime, I will keep troubleshooting and maybe trying out Virtualbox sandbox. Thanks.

Outcomes