AnsweredAssumed Answered

Error while installing mapr-librdkafka

Question asked by sagar.sonawane on Apr 25, 2017
Latest reply on May 5, 2017 by maprcommunity

I have followed instructions on Installing MapR Streams C Client and got following error

I have already done : yum install mapr-client.x86_64 and yum install mapr-posix-client-basic, each followed by configure.sh and then,

 

yum install mapr-librdkafka
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.advancedhosters.com
 * epel: mirror.cogentco.com
 * extras: mirror.lug.udel.edu
 * updates: centos.aol.com
Resolving Dependencies
--> Running transaction check
---> Package mapr-librdkafka.noarch 0:0.9.1.201703301726-1 will be installed
--> Processing Dependency: mapr-client >= 5.2.1 for package: mapr-librdkafka-0.9.1.201703301726-1.noarch
--> Running transaction check
---> Package mapr-core-internal.x86_64 0:5.2.0.39122.GA-1 will be installed
--> Processing Dependency: sdparm for package: mapr-core-internal-5.2.0.39122.GA-1.x86_64
--> Processing Dependency: redhat-lsb-core for package: mapr-core-internal-5.2.0.39122.GA-1.x86_64
--> Processing Dependency: hdparm for package: mapr-core-internal-5.2.0.39122.GA-1.x86_64
--> Running transaction check
---> Package hdparm.x86_64 0:9.43-5.el7 will be installed
---> Package redhat-lsb-core.x86_64 0:4.1-27.el7.centos.1 will be installed
--> Processing Dependency: redhat-lsb-submod-security(x86-64) = 4.1-27.el7.centos.1 for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: spax for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/time for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/patch for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/m4 for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/lp for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/bc for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/batch for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /usr/bin/at for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /bin/mailx for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
--> Processing Dependency: /bin/ed for package: redhat-lsb-core-4.1-27.el7.centos.1.x86_64
---> Package sdparm.x86_64 0:1.08-3.el7 will be installed
--> Running transaction check
---> Package at.x86_64 0:3.1.13-22.el7 will be installed
---> Package bc.x86_64 0:1.06.95-13.el7 will be installed
---> Package cups-client.x86_64 1:1.6.3-26.el7 will be installed
---> Package ed.x86_64 0:1.9-4.el7 will be installed
---> Package m4.x86_64 0:1.4.16-10.el7 will be installed
---> Package mailx.x86_64 0:12.5-12.el7_0 will be installed
---> Package patch.x86_64 0:2.7.1-8.el7 will be installed
---> Package redhat-lsb-submod-security.x86_64 0:4.1-27.el7.centos.1 will be installed
---> Package spax.x86_64 0:1.5.2-13.el7 will be installed
---> Package time.x86_64 0:1.7-45.el7 will be installed
--> Processing Conflict: mapr-client-5.2.0.39122.GA-1.x86_64 conflicts mapr-core-internal
--> Finished Dependency Resolution
Error: mapr-client conflicts with mapr-core-internal-5.2.0.39122.GA-1.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

 

We can still install by using "--skip-broken", but is there any patch needed to do "cleaner" installation?

 

Please guide.

Outcomes