AnsweredAssumed Answered

New cluster not able to start after reboot

Question asked by davidha on Mar 9, 2017
Latest reply on Mar 28, 2017 by maprcommunity

Hi, I am trying to install a single node cluster for testing purpose. I am using an EC2 instance Ububtu 14.04 and MapR5.2. The installation with the web-based installer is pretty straight forward and went smoothly. I was able to play around with the MapR services. However, if I reboot the system. The cluster is not coming up. As far as I know, the cluster should come up automatically. So I check with "service mapr-zookeeper status" and "service mapr-warden status". Zookeeper seems okay, but for warden, the following is shown:

/opt/mapr/pid/warden.pid exists with pid 4377 but no WARDEN.

 

Then I tried to restart warden by "service mapr-warden restart" the following is shown:

 

* Restarting warden daemon warden WARDEN not running.
looking to stop mapr-core processes not started by warden
start: Job is already running: irqbalance
Starting WARDEN, logging to /opt/mapr/logs/warden.log.
For diagnostics look at /opt/mapr/logs/ for createsystemvolumes.log, warden.log and configured services log files

 

Still no luck after restarting, so I check the /opt/mapr/logs directory for more information. I found that every time I try to restart warden, a new warden log file is created instead of appending to the end of the original one. I check the log in the latest "warden.log.8" , the content is as the following:

 

Stop warden
WARDEN not running.
looking to stop mapr-core processes not started by warden
CLDB not running.
Waiting up to 30 seconds ...
Wed Mar 8 07:44:29 UTC 2017
Start warden

 

I noticed it told me that CLDB is not running, but when I read through some document, seems like I should only need to start zookeeper and warden and other essential services will come up automatically Starting Up a Cluster - MapR 5.0 Documentation - doc.mapr.com . Any idea?

Attachments

Outcomes