AnsweredAssumed Answered

Mapr 5.2 installation failed on fresh Ubuntu 14.04

Question asked by inkrement on Feb 5, 2017
Latest reply on Feb 23, 2017 by maprcommunity

I rented a new server (Ubuntu 14.04) and installed the installer. I was able to access the web-gui and selected the single node. The server has a 256GB SSD (/dev/sda), which seems to make troubles:

 

The web-installer fails to install MapR with the following error:

Failed to format /dev/sda1 for MapR-FS. Review /opt/mapr/logs/disksetup.0.log, address the reported issues and retry installation

 

So I directly connected to the node using ssh and looked at the log file:

2017-02-05 14:03:07,676 18087 RunCmd:247 INFO Fileserver stop:
/opt/mapr/initscripts/mapr-mfs stop
2017-02-05 14:03:08,872 18087 ExitDiskSetup:210 ERROR Error 3, No such process. Unable to reach mfs. Check for errors in mfs.log.[' File "/opt/mapr/server/disksetup", line 1398, in <module>\n RunDiskSetup();\n', ' File "/opt/mapr/server/disksetup", line 1274, in RunDiskSetup\n GetMfsUp();\n', ' File "/opt/mapr/server/disksetup", line 1167, in GetMfsUp\n AbortWithError(errno.ESRCH, msg);\n', ' File "/opt/mapr/server/disksetup", line 240, in AbortWithError\n stack_trace = traceback.format_stack(frame)\n']

I tried to run disksetup manually (as described in the manual):

root@c1:/opt/mapr/server# /opt/mapr/server/disksetup -F /tmp/disks.txt
Error 3, No such process. Unable to reach mfs. Check for errors in mfs.log.

 

I also tried to restart mfs:

root@c1:/opt/mapr/server# service mapr-mfs restart
* Restarting mfs daemon mfs
Waiting up to 30 seconds ...
grep: /opt/mapr/conf/disktab: No such file or directory
WARNING: Fileserver will use default memory settings. To use
correct memory settings, fileserver should be started using:
maprcli node services -fileserver start -nodes <node-hostname/ip>
INFO: Fileserver not configured for MapR-DB
...done.

 

Could someone help me? Would really like to try MapR

Outcomes