AnsweredAssumed Answered

ADM203: Trying to get an Alarm Raised in Sandbox demo.mapr.com and also in my AWS cluster

Question asked by stealthfrognz on Jan 25, 2017
Latest reply on Feb 1, 2017 by aalvarez

Hi:

I wanted to force an alarm to be raised in my sandbox environment and subsequently tried the same in my 3 Node AWS MapR cluster I setup.  I checked to see what alarms were configured with

with $ maprcli alarm config load as a putty session on the sandbox and the output seems to show that the alarm is enabled:

So on MCS, I stopped the JobHistoryServer, waited and no alarms show up on MCS after refreshing.

 

Waited 15 minutes, no alarm in MCS so checked with $ maprcli alarm list and not output returned either

 

1) am I doing this correctly and the alarm appear?

2) why is this not working.

I am going to check on this function with my newly installed cluster in AWS, but just wanted to find out what the issue is.  (Followup, I have done this and no alarm raised.  I am getting alarms - like the license alerm, but was expecting one for the job history server)

 

Here are the snips from my AWS cluster when I took job history server down 15 minutes prior (am expecting an alarm):

 

Awhile later the license alarm shows, so I know that alarms are working

 

Job history alerting is set to Standard Notification (which means the dashboard alerts?)

On the node itself just confirming that alarms show on maprcli alarm list

And that on the node it is set using the maprcli alarm config load

I force the alarm to be raised and rerun maprcli alarm list and can see them

 

Here on the more detailed node information, you can see it is down...

So, I tried to force the alarm by raising it on the node followed by a maprcli alarm list and I can now see the job history server down

 

Go back to the main dashboard.. and now have the alert

but only because I have raised the alarm.

I start the job history server on the node and it shows it is running on that node but thinks it is down on the other nodes

Why didn't it pick it up naturally?

Outcomes