AnsweredAssumed Answered

5.2 ResourceManager can't connect to node: Port 39095?

Question asked by Terry on Sep 23, 2016
Latest reply on Oct 14, 2016 by Terry

Hello, I've just upgraded from 5.1 to 5.2 and made YARN primary. When submitting jobs, as jobs start, it hangs when the job is being initialized with the node manager. The eventual error was "No route to host", which normally implies a network error. After checking the ports open for each device type in iptables, I still get the same error - to an assortment of nodes, all of which can ping each other.

 

I decided to run tcpdump on the RM and see what was happening. I see an exchange between the RM:8031  and node:39888 (in this case). I then see the RM:52296 try to connect to the host:39095, which results in an ICMP "Host administratively prohibited" reply.

 

So I take out the big hammer and turn off iptabels on ALL the nodes, and it works just fine. Have I missed something with the ports required? (which I can't find for 5.2 owing to the hosed up documentation / search that always points to an old version instead of the current version).

 

thanks

Outcomes