AnsweredAssumed Answered

Jobs showing zero progress on 3 node cluster

Question asked by asadali on Jul 19, 2016
Latest reply on Jul 19, 2016 by ryanvictory

I have set up a 3-node cluster. The roles for each are

 

Node1

cldb

fileserver

jobtracker

nfs

tasktracker

webserver

zookeeper

 

Node2

fileserver

historyserver

jobtracker

resourcemanager

tasktracker

zookeeper

 

Node3

fileserver

tasktracker

zookeeper

 

 

I'm trying to run the example program from the mapr documentation as follows. I execute this on Node2

>> yarn jar /opt/mapr/hadoop/hadoop-0.20.2/hadoop-0.20.2-dev-examples.jar pi 2 50

 

Number of Maps  = 2

Samples per Map = 50

Wrote input for Map #0

Wrote input for Map #1

Starting Job

16/07/19 12:26:20 INFO client.RMProxy: Connecting to ResourceManager at node2.sensorplatforms.com/10.252.101.74:8032

16/07/19 12:26:20 INFO input.FileInputFormat: Total input paths to process : 2

16/07/19 12:26:20 INFO mapreduce.JobSubmitter: number of splits:2

16/07/19 12:26:21 INFO mapreduce.JobSubmitter: Submitting tokens for job: job_1468955179051_0003

16/07/19 12:26:21 INFO security.ExternalTokenManagerFactory: Initialized external token manager class - com.mapr.hadoop.yarn.security.MapRTicketManager

16/07/19 12:26:21 INFO impl.YarnClientImpl: Submitted application application_1468955179051_0003

16/07/19 12:26:21 INFO mapreduce.Job: The url to track the job: http://node2:8088/proxy/application_1468955179051_0003/

16/07/19 12:26:21 INFO mapreduce.Job: Running job: job_1468955179051_0003

16/07/19 12:33:56 INFO mapreduce.Job: Job job_1468955179051_0003 running in uber mode : false

 

 

At this point, I expect map 0%, reduce 0% and then for it to start progressing, but it doesn't do anything for a while. Here is what I get from

>> yarn application -list

Total number of applications (application-types: [] and states: [SUBMITTED, ACCEPTED, RUNNING]):1

                Application-Id        Application-Name        Application-Type          User         Queue                 State           Final-State           Progress                           Tracking-URL

application_1468955179051_0003         QuasiMonteCarlo               MAPREDUCE          mapr     root.mapr              ACCEPTED             UNDEFINED                 0%      

 

Another peculiarity is that the webserver dies when I start the job. Any hint on what's breaking or what logs to look at?

 

Thanks!

Outcomes