AnsweredAssumed Answered

Installing mapr-metrics on Ubuntu 16.04

Question asked by asadali on Jul 15, 2016
Latest reply on Jul 16, 2016 by mufeed

I've got a cluster up and running, and want to install mapr-metrics. However, I'm stuck at step 1, installing the package!

 

Here is what I get

>> sudo apt-get install mapr-metrics

Reading package lists... Done

Building dependency tree      

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

mapr-metrics : Depends: libmysqlclient16 (>= 5.1.47) but it is not installable or

                         libmysqlclient18 (>= 5.5.24) but it is not installable

E: Unable to correct problems, you have held broken packages.

When I do sudo apt-get install libmysqlclient, I get version 20. Any help would be appreciated. Thanks!

Outcomes