AnsweredAssumed Answered

disksetup issues when running

Question asked by divyangjp on Jun 26, 2016
Latest reply on Jul 6, 2016 by mufeed

Hi Team,

When I run, disksetup fails with below error


from /opt/mapr/logs/configure.log




2016-06-27 15:03:34.801 arya Install UpdateWardenConfig:1715 Updating Warden config

2016-06-27 15:03:34.828 arya Install RunDiskSetup:445 Running disksetup: "/opt/mapr/server/disksetup -F /tmp/disks.txt"

2016-06-27 15:03:58.255 arya Install StartCluster:268 No /opt/mapr/conf/disktab file, not starting cluster automatically

2016-06-27 15:03:58.259 arya Install StartCluster:269 Run /opt/mapr/server/disksetup manually

2016-06-27 15:03:58.263 arya Install main:2952

2016-06-27 15:03:58.267 arya Install main:2953 Node install FINISHED

2016-06-27 15:03:58.271 arya Install main:2954 -----------------------



After this step, when I run disksetup maually using,

$ /opt/mapr/server/disksetup -G -F /tmp/disks.txt


It gives error:

"/dev/sdb failed. Error 52, Invalid exchange. Failed to find the size of the disk"


/dev/sdb/ is not mounted nor formatted as required.


P.S. : It's physical node