AnsweredAssumed Answered

Impossible to remove mapr!

Question asked by gfi on Jun 16, 2016
Latest reply on Jul 28, 2016 by mufeed

We were able to remove all packages but mapr-hue and mapr-hue-base are just impossible to remove even with brute force removal tools such as dpkg --force-depends --purge, as the following error appears:

 

dpkg: mapr-hue-base: dependency problems, but removing anyway as you requested:
 mapr-hue depends on mapr-hue-base (>= 3.9.0.201511191616).
(Reading database ... 176443 files and directories currently installed.)
Removing mapr-hue-base (3.9.0.201511191616) ...
sudo: /opt/mapr/hue/hue-3.9.0/bin/hue.sh: command not found
dpkg: error processing package mapr-hue-base (--remove):
 subprocess installed pre-removal script returned error exit status 1
+ set -e
+ export DESKTOP_LOGLEVEL=WARN
+ export DESKTOP_LOG_DIR=/opt/mapr/hue/hue-3.9.0/logs/
+ . /opt/mapr/hue/hue-3.9.0/build/env/bin/activate
/var/lib/dpkg/info/mapr-hue-base.postinst: 20: .: Can't open /opt/mapr/hue/hue-3.9.0/build/env/bin/activate
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 mapr-hue-base

 

Trying to install mapr means the script stops telling

 

E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
ERROR: Unable to install dependencies (python-pycurl openssh-client openssl
libssl1.0.0 sshpass sudo wget). Ensure that a core OS repo is enabled and retry
mapr-setup.sh

 

Finally, running apt-get -f install means getting a lot of the stuff reinstalled only to end at an error.

 

And then you go back to remove all the modules to finally get stuck AGAIN with mapr-hue and mapr-hue-base

 

We are trying to reinstall it at a Lubuntu 14.4 server, as all of the sudden we could not login at mapr anymore and the node showed as being dead, even though it showed all its modules up and running.

 

VERY frustrating!

Outcomes