AnsweredAssumed Answered

Drillbit Down Alarm [after modifying conf file]

Question asked by rpillai on Mar 13, 2016
Latest reply on Mar 16, 2016 by rpillai


Mapr MCS keeps raising Drillbit Down alarm after I enabled impersonation and user authentication:

 

Here is my drill-env.sh

 

DRILL_MAX_DIRECT_MEMORY="8G"

DRILL_HEAP="4G"

export DRILL_JAVA_OPTS="-Xms$DRILL_HEAP -Xmx$DRILL_HEAP -XX:MaxDirectMemorySize=$DRILL_MAX_DIRECT_MEMORY -XX:MaxPermSize=512M -XX:ReservedCodeCacheSize=1G -Ddrill.exec.enable-epoll=true"

 

# Class unloading is disabled by default in Java 7

# http://hg.openjdk.java.net/jdk7u/jdk7u60/hotspot/file/tip/src/share/vm/runtime/globals.hpp#l1622

export SERVER_GC_OPTS="-XX:+CMSClassUnloadingEnabled -XX:+UseG1GC "

 

#export DRILL_JAVA_OPTS="$DRILL_JAVA_OPTS -Djava.security.auth.login.config=/opt/mapr/conf/mapr.login.conf -Dzookeeper.sasl.client=false "

export DRILLBIT_JAVA_OPTS="-Djava.library.path=/opt/drillpam/ -Dzookeeper.sasl.client=false"

export DRILL_LOG_DIR="/opt/mapr/drill/drill-1.4.0/logs"

export MAPR_IMPERSONATION_ENABLED=true

export MAPR_TICKETFILE_LOCATION=/opt/mapr/conf/mapruserticket

export HADOOP_HOME=/opt/mapr/hadoop/hadoop-2.7.0

 

here is my drill-override.conf:

 

drill.exec: {

  cluster-id: "mapr-clp1_hchc_local-drillbits",

  zk.connect: "my-hadoop-p1.raju.local:5181,my-hadoop-p2.raju.local:5181,my-hadoop-p3.raju.local:5181"

security.user.auth {

         enabled: true,

         packages += "org.apache.drill.exec.rpc.user.security",

         impl: "pam",

         pam_profiles: [ "sudo", "login" ]

   }

}

drill.exec.impersonation: {

        enabled: true,

         max_chained_user_hops: 3

  }

Outcomes