AnsweredAssumed Answered

Redhat 6.3 install failure: 2016-02-29 21:44:43,577 install 101 [ERROR]: Can't connect to HTTPS URL because the SSL module is not available.

Question asked by rogermitchell on Mar 1, 2016
Latest reply on Apr 19, 2016 by maprcommunity
I'm installing on Redhat 6.3.  I have successfully run mapr-setup.sh.  It installed all the required packages and passed all the other checks.  When I attempt to continue the install via the webserver, I am getting the following error in /opt/mapr/installer/logs/mapr-installer.log: 2016-02-29 21:44:43,576 connectionpool 735 [INFO]: Starting new HTTPS connection
 (1): 172.31.0.1
2016-02-29 21:44:43,577 install 101 [ERROR]: Can't connect to HTTPS URL because
the SSL module is not available.
Traceback (most recent call last):
  File "/opt/mapr/installer/bin/install.py", line 95, in run
    InstallRunner(args.cfg, **args_dict)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinst
aller-5.0.0.ui1.1.116-py2.7.egg/maprinstaller/runner/installrunner.py", line 90,
 in __init__
    self.run()
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinst
aller-5.0.0.ui1.1.116-py2.7.egg/maprinstaller/runner/installrunner.py", line 209
, in run
    self.cb_logger.process("{0} on {1}".format(label, group))
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinst
aller-5.0.0.ui1.1.116-py2.7.egg/maprinstaller/callbacks.py", line 107, in proces
s
    self.patch(url, headers, json.dumps(payload))
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/maprinst
aller-5.0.0.ui1.1.116-py2.7.egg/maprinstaller/callbacks.py", line 54, in patch
    response = self.session.patch(url, data=payload, headers=headers)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests
/sessions.py", line 530, in patch
    return self.request('PATCH', url,  data=data, **kwargs)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests
/sessions.py", line 466, in request
    resp = self.send(prep, **send_kwargs)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests
/sessions.py", line 575, in send
    r = adapter.send(request, **kwargs)
  File "/opt/mapr/installer/build/installer/lib/python2.7/site-packages/requests
/adapters.py", line 431, in send
    raise SSLError(e, request=request)
SSLError: Can't connect to HTTPS URL because the SSL module is not available.
2016-02-29 21:44:43,579 common 229 [ERROR]: Unknown Error: Can't connect to HTTP
S URL because the SSL module is not available.
2016-02-29 21:44:43,580 common 230 [ERROR]: Exiting with 1
2016-02-29 21:44:43,580 common 232 [INFO]: Asked to exit with status 1 The openssl and m2crypto packages are installed, and I can see the python /usr/lib64/python2.6/ssl.py module.  In addition, I have installed additional SSL RPMs mod_nss, erlang-ssl, mod_ssl, pyOpenSSL, ... just in case this is referring to these modules. Any ideas what the issue is?  Much thanks.

Outcomes