Package installation conflict between mapr-core and mapr-client

Document created by wade on Feb 27, 2016
Version 1Show Document
  • View in full screen mode

Author: Nabeel Moidu, last modified by Sreedhar Alagonda on May 18, 2015

 

Original Publication Date: May 2, 2015

 

Environment
This issue is seen in new installs on nodes or during upgrades and affects any version of the mapr software.

Symptom
During install time the packaging tool throws errors like :

" Processing Conflict: mapr-client-4.0.1.27334.GA-1.x86_64 conflicts mapr-core-internal"

Root Cause
The mapr-client and mapr-core packages should never be installed on the same node. The mapr-core package should only be part of the cluster nodes, and the mapr-client should be part of the non-cluster nodes. The latter is useful for nodes from where you'd like to submit jobs, or view the filesystem, install some eco-system packages etc.

Solution
Choose the appropriate package to be installed on the node, and install only one of them as required.

Attachments

    Outcomes