Setting Debug on cluster components - NFS Server

Document created by wade on Feb 27, 2016
Version 1Show Document
  • View in full screen mode

Author: Nabeel Moidu

Original Publication Date: November 11, 2014

 

NFS

Troubleshooting NFS

If it is taking a long time to get a response from the MapR NFS server, we will need to turn on operation level debug logging on the NFS server so that we can figure out whats happening.

To enable NFS debug logging, you should first identify the specific node that you are mounted to and then run the following commands:

maprcli trace dump -port 9998 -host localhost 
maprcli trace setlevel -level debug -port 9998 -host localhost
maprcli trace setmode -mode continuous -port 9998 -host localhost

 

You can check/verify the debug logging on the port by issuing the command:  
maprcli trace info -port 9998

 

If "debug" is turned on then it will show the the modules as "DEBUG" in this case

You can run these while logged in to that node directly, or replace “localhost” with the actual hostname or IP of the NFS node.

This can be done from the config file by changing the Loglevel parameter in the /opt/mapr/conf/nfsserver.conf to DEBUG

[root@nmk-rh5-2 conf]# cat nfsserver.conf | grep -i log 
#Loglevel = DEBUG | INFO | WARN | ERROR | CRITICAL | OFF
#Loglevel = INFO

 

  This will enable debug logging and once its turned on you should recreate the issue. You will have to save the output shown on your command line session where you are running the “ls”. Also, as you run the “ls” commands, run something like “date +%s%N” before and after each “ls” so u know what time the issue was occurring.

Once you have reproduced the issue, you should immediately turn debug logging off so as to avoid having the logs reach their max size and rotate out. To return the logging to its default state, run:

maprcli trace setlevel -level default -port 9998 -host localhost 
maprcli trace setmode -mode default -port 9998 -host localhost

 

Depending on how much NFS traffic you generate, you may actually need to increase the max size of the NFS log files which you can do by editing /opt/mapr/conf/nfsserver.conf, add a line like this:

MaxLogFileSize=10000

 

 

 

Attachments

    Outcomes