MapR Metrics installation fails with error 'Error: Package: mapr-metrics-x.x.x.x86_64 Requires: soci-mysql'

Document created by nobin on Feb 8, 2016
Version 1Show Document
  • View in full screen mode

Author: Nobin Kuriakose

 

Original Publication Date: May 5, 2015

 

 

Env:

  • MapR 4.x
  • MapR 3.x

Symptom:

1. Below error messages are displayed while trying to install mapr-metrics package

 

[root@node1 ~]# yum install mapr-metrics

Loaded plugins: fastestmirror, security

Loading mirror speeds from cached hostfile

* base: mirror.san.fastserv.com

* extras: mirrors.sonic.net

* updates: mirrors.sonic.net

Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package mapr-metrics.x86_64 0:3.1.1.26113.GA-1 will be installed

--> Processing Dependency: soci-mysql for package: mapr-metrics-3.1.1.26113.GA-1.x86_64

--> Finished Dependency Resolution

Error: Package: mapr-metrics-3.1.1.26113.GA-1.x86_64 (maprtech)

           Requires: soci-mysql

Root Cause:

1. EPEL repository was not enabled on the node

Solutions:

1. Enable EPEL repository on the node

Reference: http://doc.mapr.com/display/MapR/Installing+MapR+Software#InstallingMapRSoftware-getpackagesStep1:PreparePackagesandRepositories

2. Or install the dependency packages manually

 

[root@node1 ~]# repoquery --requires --resolve mapr-metrics

mapr-metrics-0:3.1.1.26113.GA-1.x86_64

bash-0:4.1.2-29.el6.x86_64

mysql-connector-java-1:5.1.17-6.el6.noarch

mapr-core-0:3.1.1.26113.GA-1.x86_64

soci-mysql-0:3.2.2-2.el6.x86_64

soci-mysql-0:3.2.2-2.el6.i686

Attachments

    Outcomes